summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKim De Mey <kim.demey@gmail.com>2014-06-11 10:37:32 +0200
committerKim De Mey <kim.demey@gmail.com>2014-06-11 10:37:32 +0200
commit20e629284f94e0c8a14e8425309c913b6ee5b280 (patch)
tree070ccfba48eeb86762695fb42a476c4c2da639d1 /configure.ac
parente73951f3d1928591b3a9a60de11ae975a21e621f (diff)
Detect endianness at configuration with Autoconf AC_C_BIGENDIAN feature
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8171c21f..238405e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,12 @@ if test $have___thread = yes; then
fi
AC_MSG_RESULT($have___thread)
+AC_C_BIGENDIAN(
+ AC_DEFINE([IEEE_MC68k], 1, [machine is bigendian]),
+ AC_DEFINE([IEEE_8087], 1, [machine is littleendian]),
+ AC_MSG_ERROR(unknown endianess),
+ AC_MSG_ERROR(universial endianess not supported)
+)
AC_SUBST([BUNDLER], ["$bundle_cmd"])