summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2017-02-23 22:26:53 -0600
committerNicolas Williams <nico@cryptonector.com>2017-02-23 22:26:53 -0600
commit06f20603f6022b721fa6a001969fbbb1111f113d (patch)
tree23eed72661434e5f672c093c6e65f625e092a8ad /configure.ac
parent607a9e3912434b5274bdce453738b63f78b76c57 (diff)
Add `localtime` and `strflocaltime` (fix #1349)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a1e51c4..02c42842 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,6 +127,8 @@ AC_FIND_FUNC([strftime], [c], [#include <time.h>], [0, 0, 0, 0])
AC_FIND_FUNC([timegm], [c], [#include <time.h>], [0])
AC_FIND_FUNC([gmtime_r], [c], [#include <time.h>], [0, 0])
AC_FIND_FUNC([gmtime], [c], [#include <time.h>], [0])
+AC_FIND_FUNC([localtime_r], [c], [#include <time.h>], [0, 0])
+AC_FIND_FUNC([localtime], [c], [#include <time.h>], [0])
AC_FIND_FUNC([gettimeofday], [c], [#include <time.h>], [0, 0])
AC_CHECK_MEMBER([struct tm.tm_gmtoff], [AC_DEFINE([HAVE_TM_TM_GMT_OFF],1,[Define to 1 if the system has the tm_gmt_off field in struct tm])],
[], [[#include <time.h>]])