summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMattias Wadman <mattias.wadman@gmail.com>2023-08-12 20:18:45 +0200
committerGitHub <noreply@github.com>2023-08-12 20:18:45 +0200
commitfdab39bc7b8d41c1ae410f03a42afc10a9322c99 (patch)
treebbc3acf5253585e348a720b4706bd0427e81e392 /Makefile.am
parent5a52553a3be6ef3e44928cab20f96cdaa3e8b5dc (diff)
Build windows 64bit binary using UCRT64 (#2832)
* Build windows 64bit binary using UCRT64 Is the default and recommended msystem setting. Will produce binaries that are compatible with windows 10 and later. Also run tests for 32bit build. Related to #2831 * Use jq -b in tests/shtest * Add Windows strptime * Make Windows-optional tests not run on Windows again --------- Co-authored-by: Nicolas Williams <nico@cryptonector.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b2b666ec..2cd6b5f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,7 +133,10 @@ endif
### Tests (make check)
-TESTS = tests/optionaltest tests/mantest tests/jqtest tests/shtest tests/utf8test tests/base64test
+TESTS = tests/mantest tests/jqtest tests/shtest tests/utf8test tests/base64test
+if !WIN32
+TESTS += tests/optionaltest
+endif
AM_TESTS_ENVIRONMENT = JQ=$(abs_builddir)/jq NO_VALGRIND=$(NO_VALGRIND)
# This is a magic make variable that causes it to treat tests/man.test as a