summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2023-07-10 18:29:03 -0500
committerEmanuele Torre <torreemanuele6@gmail.com>2023-07-30 04:25:54 +0200
commitf733a1535ed46ee7a021269c1b10eb6b27821d92 (patch)
tree6ea0a9490317f343dc387d40bdb9796ee58c398e /Makefile.am
parentc8b30dff4a573e5efc23e30a5074011e39832e2c (diff)
Use -Wno-cast-function-type to quiet many warnings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ad284078..e3b3e5a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,8 @@ LIBJQ_SRC = src/builtin.c src/bytecode.c src/compile.c src/execute.c \
### C build options
AM_CFLAGS = -Wextra -Wall -Wno-missing-field-initializers \
- -Wno-unused-parameter -Wno-unused-function
+ -Wno-unused-parameter -Wno-unused-function \
+ -Wno-cast-function-type
if WIN32
AM_CFLAGS += -municode