summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Langford <wlangfor@gmail.com>2017-01-24 23:05:47 -0500
committerWilliam Langford <wlangfor@gmail.com>2017-01-27 21:04:26 -0500
commite84d17196c03da6e6dc56f4fcd319a7fe84f8dbc (patch)
treea69bd988a82c256dbeb78c045137e08b1da55325 /Makefile.am
parentfd4ae8304e23007672af9a37855c7a76de7c78cf (diff)
Handle cut-off UTF-8 sequences when reading files
Read additional bytes from the file to complete the UTF-8 sequence so the bytes in it don't get converted to U+FFFD replacement characters.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a3aded4..c1eaf6de 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,7 +115,7 @@ endif
### Tests (make check)
-TESTS = tests/optionaltest tests/mantest tests/jqtest tests/onigtest tests/shtest
+TESTS = tests/optionaltest tests/mantest tests/jqtest tests/onigtest tests/shtest tests/utf8test
TESTS_ENVIRONMENT = NO_VALGRIND=$(NO_VALGRIND)