summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2015-06-27 09:52:12 -0700
committerDavid Tolnay <dtolnay@gmail.com>2015-06-27 11:24:53 -0700
commitd7e35101c537a8ec7c86e8e19313e8a20dd72ce3 (patch)
tree435c4d7b815d6680b4cf50d0b585a204eeae6420 /Makefile.am
parent1defaa7b00a18118e8bb8d55dc8b4ec69e319796 (diff)
add configure option to run tests without valgrind
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d335daa..8598f4c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,14 @@ libjq_la_LDFLAGS = -export-symbols-regex '^j[qv]_' -version-info 1:4:0
include_HEADERS = jv.h jq.h
+### Running tests under Valgrind
+
+if ENABLE_VALGRIND
+NO_VALGRIND =
+else
+NO_VALGRIND = 1
+endif
+
### Error injection for testing
if ENABLE_ERROR_INJECTION
@@ -80,6 +88,7 @@ endif
### Tests (make check)
TESTS = tests/mantest tests/jqtest tests/onigtest tests/shtest
+TESTS_ENVIRONMENT = NO_VALGRIND=$(NO_VALGRIND)
### Building the manpage