summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2015-05-18 12:07:29 -0500
committerNicolas Williams <nico@cryptonector.com>2015-05-18 12:07:29 -0500
commitcf1306f469d0efb178f567f0b43e9af0435593ca (patch)
tree5cc21ad6f03dab634ba82fa902d1f0142422b89c /Makefile.am
parent7675f7434a8ecc92bc9c95f12bf0baedada3c76e (diff)
Add -all-static when --enable-static
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1030bbbd..69da0746 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,4 @@
+
### C source files to be built and distributed.
LIBJQ_INCS = jq_parser.h builtin.h bytecode.h compile.h exec_stack.h \
@@ -71,6 +72,10 @@ jq_SOURCES = main.c version.h
jq_LDFLAGS = -static-libtool-libs
jq_LDADD = libjq.la -lm
+if ENABLE_ALL_STATIC
+jq_LDFLAGS += -all-static
+endif
+
### Tests (make check)
TESTS = tests/all.test