summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authoritchyny <itchyny@cybozu.co.jp>2023-07-18 08:17:21 +0900
committerGitHub <noreply@github.com>2023-07-18 08:17:21 +0900
commit9e4c71558aeeccc4c9c3ba4cd21451d9f3e047fc (patch)
treee7f23b744e9eca5be366d7460674c3db74d56680 /Makefile.am
parent4b3090a9abba3fa5b94a46c5f44944deec17d5d4 (diff)
Split man.test to make tests pass without oniguruma (#2722)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 662d294b..b8cd58d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,7 +134,7 @@ endif
### Tests (make check)
-TESTS = tests/optionaltest tests/mantest tests/jqtest tests/onigtest tests/shtest tests/utf8test tests/base64test
+TESTS = tests/optionaltest tests/mantest tests/jqtest tests/shtest tests/utf8test tests/base64test
AM_TESTS_ENVIRONMENT = JQ=$(abs_builddir)/jq NO_VALGRIND=$(NO_VALGRIND)
# This is a magic make variable that causes it to treat tests/man.test as a
@@ -150,9 +150,9 @@ check_DATA = tests/man.test
# Making changes to the manpage without having the python deps means your
# tests won't run. If you aren't making changes to the examples, you probably
# don't care. But if you are, then you need to run the tests anyway.
-tests/man.test: $(srcdir)/docs/content/manual/manual.yml
+tests/man.test tests/manonig.test: $(srcdir)/docs/content/manual/manual.yml
if ENABLE_DOCS
- $(AM_V_GEN) ( cd ${abs_srcdir}/docs; $(PIPENV) run python build_mantests.py ) > $@
+ $(AM_V_GEN) ( cd ${abs_srcdir}/docs; $(PIPENV) run python build_mantests.py )
else
@echo Changes to the manual.yml require docs to be enabled to update the manual test.
@echo As a result, the manual test is out of date.
@@ -186,6 +186,10 @@ endif
AM_CFLAGS += $(onig_CFLAGS)
+if WITH_ONIGURUMA
+TESTS += tests/onigtest tests/manonigtest
+endif
+
### Packaging
docs/site.yml: configure.ac
@@ -216,9 +220,9 @@ EXTRA_DIST = $(DOC_FILES) $(man_MANS) $(TESTS) $(TEST_LOG_COMPILER) \
tests/modules/test_bind_order2.jq \
tests/onig.supp tests/local.supp \
tests/setup tests/torture/input0.json \
- tests/optional.test tests/man.test tests/jq.test \
- tests/onig.test tests/base64.test tests/utf8-truncate.jq \
- tests/jq-f-test.sh
+ tests/optional.test tests/man.test tests/manonig.test \
+ tests/jq.test tests/onig.test tests/base64.test \
+ tests/utf8-truncate.jq tests/jq-f-test.sh
AM_DISTCHECK_CONFIGURE_FLAGS=--disable-maintainer-mode --with-oniguruma=builtin