summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2017-02-25 14:15:18 -0600
committerNicolas Williams <nico@cryptonector.com>2017-02-25 14:49:20 -0600
commit9801de6979e154a67fa8a771f58f5697e84761e8 (patch)
tree131c1d15498a06177786008822d55a93d9397334 /Makefile.am
parentc695f2cd9c017822acea6d2373cb3cb66698ed3a (diff)
Windows: Also use -lshlwapi for jq(1)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c3095d1..73b02ef3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,6 +109,10 @@ jq_SOURCES = src/main.c src/version.h
jq_LDFLAGS = -static-libtool-libs
jq_LDADD = libjq.la -lm
+if WIN32
+jq_LDADD += -lshlwapi
+endif
+
if ENABLE_ALL_STATIC
jq_LDFLAGS += -all-static
endif