summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Langford <wlangfor@gmail.com>2014-07-09 00:55:20 -0400
committerNicolas Williams <nico@cryptonector.com>2014-07-22 22:51:11 -0500
commit38b939688a596c2de1b3d254491005b2754c8569 (patch)
tree5a72e591ad521c9d6085c26bfd935739929543cd /Makefile.am
parent01fc8168e95bc596e22eebcb568e83660d9fe9f5 (diff)
Added library system with -l, -L, and JQ_LIBRARY_PATH
Created util.[ch] to hold common utilities.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 02f7d966..b7dd16bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,11 +2,11 @@
LIBJQ_INCS = jq_parser.h builtin.h bytecode.h compile.h exec_stack.h \
libm.h jv_alloc.h jv_dtoa.h jv_unicode.h locfile.h \
- opcode_list.h parser.y jv_utf8_tables.h lexer.l
+ opcode_list.h parser.y jv_utf8_tables.h lexer.l util.h linker.h
LIBJQ_SRC = locfile.c bytecode.c compile.c execute.c builtin.c jv.c \
jv_parse.c jv_print.c jv_dtoa.c jv_unicode.c jv_aux.c jv_file.c \
- jv_alloc.c jq_test.c ${LIBJQ_INCS}
+ jv_alloc.c jq_test.c util.c linker.c ${LIBJQ_INCS}
### C build options