summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2015-10-17 23:24:13 -0700
committerDavid Tolnay <dtolnay@gmail.com>2015-10-22 19:26:00 -0700
commit143e8dc5e41c7f8f7e2a2cf2f715ab5aa3bddfc8 (patch)
tree17ae445dfbc1f4677f15e1772132fd05c695d4a9 /Makefile.am
parentb80d58e16743bd8b3a750c6a27e8003f33a1e46e (diff)
Move jq-coded builtins to non-C file (fix #424)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 95042fbd..12121614 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,6 +86,10 @@ src/version.h: .remake-version-h
$(AM_V_GEN) $(generate_ver); echo "$$ver" > $@
src/main.c: src/version.h
+src/builtin.inc: src/builtin.jq
+ $(AM_V_GEN) sed -e 's/\\/\\\\/g' -e 's/"/\\"/g' -e 's/^/"/' -e 's/$$/\\n"/' $^ > $@
+src/main.c: src/builtin.inc
+
bin_PROGRAMS = jq
jq_SOURCES = src/main.c src/version.h
jq_LDFLAGS = -static-libtool-libs