summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorErik Brinkman <erik.brinkman@gmail.com>2017-01-26 23:29:00 -0500
committerWilliam Langford <wlangfor@gmail.com>2017-02-18 21:34:26 -0500
commit02bad4b298d4d2bc8e29c3f0d744700652cfd832 (patch)
tree9c1c33673c70307573b64c1c9d42d53ed6a96222 /Makefile.am
parent9b2179089b6f0bf78a870c0bfe2d96f1f127dd6c (diff)
Add local oniguruma submodule
Configure should still allow use of prebuilt onigurumas (whether system-installed or in a special prefix). If these are not found, and configure was not called with `--without-oniguruma`, then use the vendored oniguruma module. If configure was called with `--without-oniguruma`, then we do not build regex functionality into jq.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cf5d74dc..3c3095d1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,7 +48,7 @@ AM_YFLAGS = --warnings=all -d
lib_LTLIBRARIES = libjq.la
libjq_la_SOURCES = ${LIBJQ_SRC}
libjq_la_LIBADD = -lm
-libjq_la_LDFLAGS = -export-symbols-regex '^j[qv]_' -version-info 1:4:0
+libjq_la_LDFLAGS = $(onig_LDFLAGS) -export-symbols-regex '^j[qv]_' -version-info 1:4:0
if WIN32
libjq_la_LIBADD += -lshlwapi
@@ -133,6 +133,15 @@ jq.1: $(srcdir)/jq.1.prebuilt
endif
+### Build oniguruma
+
+if BUILD_ONIGURUMA
+libjq_la_LIBADD += modules/oniguruma/src/.libs/libonig.la
+SUBDIRS = modules/oniguruma
+endif
+
+AM_CFLAGS += $(onig_CFLAGS)
+
### Packaging
docs/site.yml: configure.ac