summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2019-05-17 19:50:07 -0400
committerJiayi Zhao <jeff.no.zhao@gmail.com>2019-05-17 19:50:07 -0400
commitc61675cf302f0b65d5e77810cfdc5aca5fffde48 (patch)
tree602cf8ee8d8369cbaaa91e3e671c57820fc03417 /Cargo.toml
parent0c3c35bb9c1845642b5131d0438ca7efd8778348 (diff)
update textfield to rustyline 4.1.0 api
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 12 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c5bb4d1..eea5025 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,19 +10,20 @@ edition = "2018"
[dependencies]
chrono = "0.4.6"
dirs = "1.0.5"
-fs_extra = "1.1.0"
-lazy_static = "1.3.0"
-libc = "0.2.51"
-notify = "4.0.10"
+fs_extra = "^1"
+lazy_static = "^1"
+libc = "^0.2"
+notify = "^4"
open = "1.2.2"
-rustyline = "3.0.0"
-serde = "1.0.90"
-serde_derive = "1.0.90"
+rustyline = "^4.1"
+serde = "^1"
+serde_derive = "^1"
structopt = "0.2.14"
-toml = "0.5.0"
-unicode-width = "0.1.5"
-whoami = "0.5.0"
-xdg = "2.2.0"
+text_io = "^0"
+toml = "^0"
+unicode-width = "^0"
+whoami = "^0"
+xdg = "^2"
# clap = "*"
# fs_extra = "*"