summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Zhao <jeff.no.zhao@gmail.com>2022-03-05 19:08:58 -0500
committerJeff Zhao <jeff.no.zhao@gmail.com>2022-03-05 19:08:58 -0500
commit996d1543b1291a4ae72aded64ec847bacf4c4e7f (patch)
treeb746e974f9e97fd4d49baa833fa13f199c340396 /Cargo.toml
parent8ea29a05bc8937e9177ae5cf2c112b88cdd3a68a (diff)
make ansi-to-tui optional
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e4a26b5..7276e79 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -35,7 +35,7 @@ xdg = "^2"
phf = { version = "^0", features = ["macros"], optional = true }
trash = { version = "^1", optional = true }
unicode-segmentation = "^1"
-ansi-to-tui = { git = "https://github.com/uttarayan21/ansi-to-tui" } # "^0"
+ansi-to-tui = { git = "https://github.com/uttarayan21/ansi-to-tui", optional = true } # "^0"
notify = "5.0.0-pre.13"
[features]
@@ -43,4 +43,5 @@ devicons = [ "phf" ]
file_mimetype = []
mouse = []
recycle_bin = [ "trash" ]
+syntax_highlight = [ "ansi-to-tui" ]
default = [ "devicons", "recycle_bin" ]