summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Zhao <jeff.no.zhao@gmail.com>2022-05-08 11:14:08 -0400
committerJeff Zhao <jeff.no.zhao@gmail.com>2022-05-08 11:14:08 -0400
commit2693f56086f8bcaf4e06151933cf16a0d63cb091 (patch)
tree23db4ed36611ad5efe0f5171133dd9958791b0a7 /Cargo.toml
parentd49f7ed734588dfa7d231d24379d600783398c4e (diff)
update notify dependency
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6cb5224..627df1f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,7 @@ license = "LGPL-3.0"
edition = "2018"
[dependencies]
+ansi-to-tui = { version = "^0", optional = true }
alphanumeric-sort = "^1"
chrono = "^0"
colors-transform = "^0"
@@ -16,7 +17,9 @@ filetime = "^0"
globset = "^0"
lazy_static = "^1"
libc = "^0"
+notify = "5.0.0-pre.15"
open = "^2"
+phf = { version = "^0", features = ["macros"], optional = true }
rand = "^0"
rustyline = "^4"
serde = "^1"
@@ -27,16 +30,13 @@ signal-hook = "^0"
structopt = "^0"
termion = "^1"
toml = "^0"
+trash = { version = "^1", optional = true }
tui = { version = "^0", default-features = false, features = ["termion"] }
+unicode-segmentation = "^1"
unicode-width = "^0"
users = "^0"
whoami = "^0"
xdg = "^2"
-phf = { version = "^0", features = ["macros"], optional = true }
-trash = { version = "^1", optional = true }
-unicode-segmentation = "^1"
-ansi-to-tui = { version = "^0", optional = true }
-notify = "5.0.0-pre.13"
[features]
devicons = [ "phf" ]