summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Zhao <jeff.no.zhao@gmail.com>2021-01-24 14:56:04 -0500
committerJeff Zhao <jeff.no.zhao@gmail.com>2021-01-24 14:56:45 -0500
commit25b2128bbfdf0b6b0e3431900c6b01a7b1ece080 (patch)
treea897b05b92f21ea5e0f71d7313908c34584a562c /Cargo.toml
parentc333ca13e01ec00c266cbf40ea33cb07d6270fc4 (diff)
add optional clipboard support
- make mouse support optional
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1e41971..d8d292c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,7 +23,6 @@ shellexpand = "^2"
signal-hook = "^0"
structopt = "^0"
termion = "^1"
-trash = "^1"
toml = "^0"
tui = "^0"
unicode-width = "^0"
@@ -31,6 +30,8 @@ users = "^0"
whoami = "^0"
xdg = "^2"
phf = { version = "^0", features = ["macros"], optional = true }
+cli-clipboard = { version = "^0", optional = true }
+trash = { version = "^1", optional = true }
# [dependencies.wordexp]
# version = "^0"
@@ -39,7 +40,9 @@ phf = { version = "^0", features = ["macros"], optional = true }
# path = "lib/wordexp-rs"
[features]
+clipboard = [ "cli-clipboard" ]
devicons = [ "phf" ]
file_mimetype = []
mouse = []
-default = [ "phf", "mouse" ]
+recycle_bin = [ "trash" ]
+default = [ "clipboard", "mouse", "phf", "recycle_bin" ]