summaryrefslogtreecommitdiffstats
path: root/lib/entry/libimagentryref/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'lib/entry/libimagentryref/Cargo.toml')
-rw-r--r--lib/entry/libimagentryref/Cargo.toml28
1 files changed, 10 insertions, 18 deletions
diff --git a/lib/entry/libimagentryref/Cargo.toml b/lib/entry/libimagentryref/Cargo.toml
index e82249b9..60692acd 100644
--- a/lib/entry/libimagentryref/Cargo.toml
+++ b/lib/entry/libimagentryref/Cargo.toml
@@ -20,27 +20,19 @@ is-it-maintained-open-issues = { repository = "matthiasbeyer/imag" }
maintenance = { status = "actively-developed" }
[dependencies]
-itertools = "0.7"
-log = "0.4.0"
-toml = "0.4"
-toml-query = "0.8"
-failure = "0.1"
-sha-1 = { version = "0.7", optional = true }
-sha2 = { version = "0.7", optional = true }
-sha3 = { version = "0.7", optional = true }
-hex = { version = "0.3", optional = true }
+itertools = "0.7"
+log = "0.4.0"
+failure = "0.1"
+sha-1 = "0.8"
+toml = "0.4"
+toml-query = "0.8"
+serde = "1"
+serde_derive = "1"
libimagstore = { version = "0.10.0", path = "../../../lib/core/libimagstore" }
libimagerror = { version = "0.10.0", path = "../../../lib/core/libimagerror" }
libimagentryutil = { version = "0.10.0", path = "../../../lib/entry/libimagentryutil" }
-[features]
-default = []
-generators = []
-generators-sha1 = ["sha-1", "hex"]
-generators-sha224 = ["sha2", "hex"]
-generators-sha256 = ["sha2", "hex"]
-generators-sha384 = ["sha2", "hex"]
-generators-sha512 = ["sha2", "hex"]
-generators-sha3 = ["sha3", "hex"]
+[dev-dependencies]
+env_logger = "0.5"