summaryrefslogtreecommitdiffstats
path: root/lib/entry/libimagentryurl/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2019-06-30 16:44:23 +0200
committerMatthias Beyer <mail@beyermatthias.de>2019-06-30 16:44:23 +0200
commit2185d440114e2d2693863371243495048dc7d349 (patch)
tree3a1d7457a92241183eb54d2a99fb4b027002c33c /lib/entry/libimagentryurl/Cargo.toml
parentf1ad4500335cdec4e3ed4f4c8b99130ad70637ea (diff)
Update all dependencies
This patch updates all dependencies but not "nom". Done with `cargo upgrade --all` and manual editing. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'lib/entry/libimagentryurl/Cargo.toml')
-rw-r--r--lib/entry/libimagentryurl/Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/lib/entry/libimagentryurl/Cargo.toml b/lib/entry/libimagentryurl/Cargo.toml
index 5b17404b..90d641ef 100644
--- a/lib/entry/libimagentryurl/Cargo.toml
+++ b/lib/entry/libimagentryurl/Cargo.toml
@@ -20,17 +20,17 @@ is-it-maintained-open-issues = { repository = "matthiasbeyer/imag" }
maintenance = { status = "actively-developed" }
[dependencies]
-itertools = "0.7"
-log = "0.4.0"
-toml = "0.5"
-url = "1.5"
-sha-1 = "0.7"
-hex = "0.3"
-is-match = "0.1"
-failure = "0.1"
-failure_derive = "0.1"
-serde = "1"
-serde_derive = "1"
+itertools = "0.8.0"
+log = "0.4.6"
+toml = "0.5.1"
+url = "1.7.2"
+sha-1 = "0.8.1"
+hex = "0.3.2"
+is-match = "0.1.0"
+failure = "0.1.5"
+failure_derive = "0.1.5"
+serde = "1.0.94"
+serde_derive = "1.0.94"
libimagstore = { version = "0.10.0", path = "../../../lib/core/libimagstore" }
libimagerror = { version = "0.10.0", path = "../../../lib/core/libimagerror" }
@@ -38,10 +38,10 @@ libimagutil = { version = "0.10.0", path = "../../../lib/etc/libimagutil" }
libimagentrylink = { version = "0.10.0", path = "../../../lib/entry/libimagentrylink" }
[dependencies.toml-query]
-version = "0.9"
+version = "0.9.2"
default-features = false
features = [ "typed" ]
[dev-dependencies]
-env_logger = "0.5"
+env_logger = "0.6.1"