summaryrefslogtreecommitdiffstats
path: root/lib/domain/libimagmail/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2019-02-17 11:44:54 +0100
committerMatthias Beyer <mail@beyermatthias.de>2019-02-17 11:44:54 +0100
commitc562f352223fe5732424e5302a37c88698e3a1b4 (patch)
tree17a1e6628d7dc2d5acafe6d7aa14256f70ea458c /lib/domain/libimagmail/Cargo.toml
parent820ac41443d829e9e0c56cc58a915fa4e5fbd2c3 (diff)
parentf9a980c344227898df1fec54a41c84275f7325b2 (diff)
Merge branch 'rewrite-libimagentryref'
This is the merge for the "ref"-infrastructure rewrite. Finally. The refs are now stored with three bits of information: * The "collection" (named basepath) * The "relpath" (relative path) * The hash (sha1 as of now) The "collection" is a name which has to be accociated with a path to a directory (in the config file). That gives the user the opportunity to have (for example) their music collection in $HOME/music on one device and in $HOME/media/music on another. The "relpath" is the relative path, which results in the path to the actual file when being joined with the "collection" path. The hash is a sha1 hash as of now. Re-checking this hash with libimagentryref is not yet tested. This merge also removes the "mail" code completely, for the sake of seperating concerns into branches. The respective commits might be removed later. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'lib/domain/libimagmail/Cargo.toml')
-rw-r--r--lib/domain/libimagmail/Cargo.toml30
1 files changed, 0 insertions, 30 deletions
diff --git a/lib/domain/libimagmail/Cargo.toml b/lib/domain/libimagmail/Cargo.toml
deleted file mode 100644
index 294040f3..00000000
--- a/lib/domain/libimagmail/Cargo.toml
+++ /dev/null
@@ -1,30 +0,0 @@
-[package]
-name = "libimagmail"
-version = "0.10.0"
-authors = ["Matthias Beyer <mail@beyermatthias.de>"]
-
-description = "Library for the imag core distribution"
-
-keywords = ["imag", "PIM", "personal", "information", "management"]
-readme = "../../../README.md"
-license = "LGPL-2.1"
-
-documentation = "https://imag-pim.org/doc/"
-repository = "https://github.com/matthiasbeyer/imag"
-homepage = "http://imag-pim.org"
-
-[badges]
-travis-ci = { repository = "matthiasbeyer/imag" }
-is-it-maintained-issue-resolution = { repository = "matthiasbeyer/imag" }
-is-it-maintained-open-issues = { repository = "matthiasbeyer/imag" }
-maintenance = { status = "actively-developed" }
-
-[dependencies]
-log = "0.4.0"
-email = "0.0.20"
-filters = "0.3"
-failure = "0.1"
-
-libimagstore = { version = "0.10.0", path = "../../../lib/core/libimagstore" }
-libimagerror = { version = "0.10.0", path = "../../../lib/core/libimagerror" }
-libimagentryref = { version = "0.10.0", path = "../../../lib/entry/libimagentryref" }