summaryrefslogtreecommitdiffstats
path: root/lib/core/libimagstore/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-08-13 21:48:17 +0000
committerMatthias Beyer <mail@beyermatthias.de>2017-08-27 15:12:09 +0200
commit59a3662ac47b0c657781bd1db34bbf9a5a692326 (patch)
tree709f72c44c8d978a5a76abb9036c6f08744a4aa2 /lib/core/libimagstore/Cargo.toml
parent31254071e5a4bf2f5db9067c5cdb22c25579ac67 (diff)
Reorganize code in subdirs
Diffstat (limited to 'lib/core/libimagstore/Cargo.toml')
-rw-r--r--lib/core/libimagstore/Cargo.toml73
1 files changed, 73 insertions, 0 deletions
diff --git a/lib/core/libimagstore/Cargo.toml b/lib/core/libimagstore/Cargo.toml
new file mode 100644
index 00000000..c5fb527f
--- /dev/null
+++ b/lib/core/libimagstore/Cargo.toml
@@ -0,0 +1,73 @@
+[package]
+name = "libimagstore"
+version = "0.4.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+
+description = "Library for the imag core distribution"
+
+keywords = ["imag", "PIM", "personal", "information", "management"]
+readme = "../README.md"
+license = "LGPL-2.1"
+
+documentation = "https://matthiasbeyer.github.io/imag/imag_documentation/index.html"
+repository = "https://github.com/matthiasbeyer/imag"
+homepage = "http://imag-pim.org"
+
+[dependencies]
+fs2 = "0.4"
+glob = "0.2.11"
+lazy_static = "0.2.*"
+log = "0.3"
+regex = "0.2"
+semver = "0.5"
+toml = "^0.4"
+version = "2.0.1"
+crossbeam = "0.2.*"
+walkdir = "1.0.*"
+itertools = "0.6.*"
+is-match = "0.1"
+serde = "1.0"
+serde_json = "1.0"
+serde_derive = "1.0"
+
+libimagerror = { version = "0.4.0", path = "../../../lib/core/libimagerror" }
+libimagutil = { version = "0.4.0", path = "../../../lib/etc/libimagutil" }
+
+[dev-dependencies]
+tempdir = "0.3.4"
+env_logger = "0.3"
+
+[features]
+default = []
+verify = []
+
+# Enable panic!()s if critical errors occur.
+#
+# # Howto
+#
+# To enable this, put
+#
+# ```toml
+# [features]
+# early-panic = [ "libimagstore/early-panic" ]
+# ```
+#
+# In the crate depending on this library and compile your crate with
+# `cargo build --features early-panic`. This way, the `libimagstore`
+# implementation fails via `panic!()` instead of propagating errors which have
+# to be printed somewhere to be visible.
+#
+# # WARNING
+#
+# The behaviour of the store implementation might be broken with this, resulting
+# in partially written store entries and/or worse, so this is
+#
+# _NOT INTENDED FOR PRODUCTION USE_!
+#
+early-panic=[]
+
+# File system locking
+#
+# Enable this feature to enable file-system locking in the store.
+fs-locking = []
+