summaryrefslogtreecommitdiffstats
path: root/lib/core/libimagstore/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-09-18 14:53:04 +0200
committerMatthias Beyer <mail@beyermatthias.de>2017-09-19 17:16:19 +0200
commit162b36d6ee163527c014126735920695815dded7 (patch)
tree6ec5a3f826cc71a9fa696ca8104b7bebf5328865 /lib/core/libimagstore/Cargo.toml
parent2cee0db1eca581ecac917c898b133e9e43716cc3 (diff)
Update dependency specs
Most notably: * env_logger: 0.4 -> 0.5 * hoedown: 5.0.0 -> 6.0.0 * itertools: 0.5 -> 0.6 * lazy_static: 0.1.15 -> 0.2 * regex: 0.1 -> 0.2 * semver: 0.5 -> 0.8 * url: 1.2 -> 1.5 * uuid: 0.3 -> 0.5 (This list is most surely not complete)
Diffstat (limited to 'lib/core/libimagstore/Cargo.toml')
-rw-r--r--lib/core/libimagstore/Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/lib/core/libimagstore/Cargo.toml b/lib/core/libimagstore/Cargo.toml
index 94af976e..ce56a675 100644
--- a/lib/core/libimagstore/Cargo.toml
+++ b/lib/core/libimagstore/Cargo.toml
@@ -15,25 +15,25 @@ homepage = "http://imag-pim.org"
[dependencies]
glob = "0.2.11"
-lazy_static = "0.2.*"
+lazy_static = "0.2"
log = "0.3"
regex = "0.2"
-semver = "0.5"
-toml = "^0.4"
+semver = "0.8"
+toml = "0.4"
version = "2.0.1"
-walkdir = "1.0.*"
+walkdir = "1"
is-match = "0.1"
-serde = "1.0"
-serde_json = "1.0"
-serde_derive = "1.0"
+serde = "1"
+serde_json = "1"
+serde_derive = "1"
error-chain = "0.10"
libimagerror = { version = "0.4.0", path = "../../../lib/core/libimagerror" }
libimagutil = { version = "0.4.0", path = "../../../lib/etc/libimagutil" }
[dev-dependencies]
-tempdir = "0.3.4"
-env_logger = "0.3"
+tempdir = "0.3"
+env_logger = "0.4"
[features]
default = []