summaryrefslogtreecommitdiffstats
path: root/lib/core/libimagrt/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2018-10-31 23:01:52 +0100
committerMatthias Beyer <mail@beyermatthias.de>2018-10-31 23:10:26 +0100
commit59f16d0eab6084dbb6e4f46f2002247092580eaf (patch)
treeb49ff6d6a75df91b79ca70678f3f30ccfc2a6dcf /lib/core/libimagrt/Cargo.toml
parent84f2f2c46f79ab47d3e5c1de2100b11bfa1a6381 (diff)
Add feature: Public logging initialization
This feature is required for the `imag` binary. It allows the binary to use the imag internal logger for logging its own log output. We need to be able to initialize the logger from an external module (in all imag modules, the Runtime::new() implementation takes care of this, but as we cannot use that in the `imag` binary itself, we allow this method to be public behind a feature flag). Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'lib/core/libimagrt/Cargo.toml')
-rw-r--r--lib/core/libimagrt/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/core/libimagrt/Cargo.toml b/lib/core/libimagrt/Cargo.toml
index 7c31ae64..611a49c2 100644
--- a/lib/core/libimagrt/Cargo.toml
+++ b/lib/core/libimagrt/Cargo.toml
@@ -53,6 +53,11 @@ features = ["no_logging"]
[features]
default = []
+# Make logger initialization inside `runtime::Runtime` public.
+# This feature is _only_ used for the `imag` binary itself. You do not need this
+# feature and if you think you do you're doing it wrong.
+pub_logging_initialization = []
+
# Enable testing functionality. Used for building the libimagrt for testing CLI
# apps. Do not use in production!
testing = []