summaryrefslogtreecommitdiffstats
path: root/bin/domain/imag-todo/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-08-13 21:48:17 +0000
committerMatthias Beyer <mail@beyermatthias.de>2017-08-27 15:12:09 +0200
commit59a3662ac47b0c657781bd1db34bbf9a5a692326 (patch)
tree709f72c44c8d978a5a76abb9036c6f08744a4aa2 /bin/domain/imag-todo/Cargo.toml
parent31254071e5a4bf2f5db9067c5cdb22c25579ac67 (diff)
Reorganize code in subdirs
Diffstat (limited to 'bin/domain/imag-todo/Cargo.toml')
-rw-r--r--bin/domain/imag-todo/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/bin/domain/imag-todo/Cargo.toml b/bin/domain/imag-todo/Cargo.toml
new file mode 100644
index 00000000..047cdd50
--- /dev/null
+++ b/bin/domain/imag-todo/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+authors = ["mario <mario-krehl@gmx.de>"]
+name = "imag-todo"
+version = "0.4.0"
+
+description = "Part of the imag core distribution: imag-todo command"
+
+keywords = ["imag", "PIM", "personal", "information", "management"]
+readme = "../README.md"
+license = "LGPL-2.1"
+
+documentation = "https://matthiasbeyer.github.io/imag/imag_documentation/index.html"
+repository = "https://github.com/matthiasbeyer/imag"
+homepage = "http://imag-pim.org"
+
+[dependencies]
+clap = ">=2.17"
+glob = "0.2.11"
+log = "0.3.6"
+semver = "0.5.1"
+serde_json = "0.8.3"
+task-hookrs = "0.2.2"
+toml = "0.4.*"
+toml-query = "0.3.*"
+is-match = "0.1.*"
+version = "2.0.1"
+
+libimagrt = { version = "0.4.0", path = "../../../lib/core/libimagrt" }
+libimagstore = { version = "0.4.0", path = "../../../lib/core/libimagstore" }
+libimagerror = { version = "0.4.0", path = "../../../lib/core/libimagerror" }
+libimagtodo = { version = "0.4.0", path = "../../../lib/domain/libimagtodo" }