summaryrefslogtreecommitdiffstats
path: root/bin/domain/imag-notes/Cargo.toml
diff options
context:
space:
mode:
authorLeon Schuermann <leon@is.currently.online>2019-09-14 18:54:34 +0200
committerMatthias Beyer <mail@beyermatthias.de>2019-10-26 14:41:31 +0200
commit6590a4b8cb67ee9e7db6526f104987a7bd4f7641 (patch)
tree11baf36b5377480a22f2220f3e781944a85dd992 /bin/domain/imag-notes/Cargo.toml
parent870a09f1dc016dd510aad17ae260e655420f4c0a (diff)
imag-notes: implement ImagApplication
Signed-off-by: Leon Schuermann <leon@is.currently.online>
Diffstat (limited to 'bin/domain/imag-notes/Cargo.toml')
-rw-r--r--bin/domain/imag-notes/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/bin/domain/imag-notes/Cargo.toml b/bin/domain/imag-notes/Cargo.toml
index 20193d86..90d15f90 100644
--- a/bin/domain/imag-notes/Cargo.toml
+++ b/bin/domain/imag-notes/Cargo.toml
@@ -22,6 +22,7 @@ maintenance = { status = "actively-developed" }
[dependencies]
log = "0.4.6"
itertools = "0.8.0"
+failure = "0.1.5"
libimagrt = { version = "0.10.0", path = "../../../lib/core/libimagrt" }
libimagerror = { version = "0.10.0", path = "../../../lib/core/libimagerror" }
@@ -35,3 +36,10 @@ version = "2.33.0"
default-features = false
features = ["color", "suggestions", "wrap_help"]
+[lib]
+name = "libimagnotesfrontend"
+path = "src/lib.rs"
+
+[[bin]]
+name = "imag-notes"
+path = "src/bin.rs"