summaryrefslogtreecommitdiffstats
path: root/bin/domain/imag-contact/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-10-10 18:48:21 +0200
committerMatthias Beyer <mail@beyermatthias.de>2017-11-09 11:19:17 +0100
commitd0ec7e26dcfd28bf20fd90d79a8c39cc42a18944 (patch)
treee0ba0e877a5a9e4db22fcf4c41381f8029bafafd /bin/domain/imag-contact/Cargo.toml
parent0540ae9392db2f887b3ef1bcdc6bc49b496655cc (diff)
Add implementation for imag-contact
* Implement contact listing with formatting via commandline or config * Implement importer functionality for contact * Implement "show" subcommand * imagrc.toml: Add explanation which fns are supported in templates
Diffstat (limited to 'bin/domain/imag-contact/Cargo.toml')
-rw-r--r--bin/domain/imag-contact/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/bin/domain/imag-contact/Cargo.toml b/bin/domain/imag-contact/Cargo.toml
index 1dac6415..e4251fed 100644
--- a/bin/domain/imag-contact/Cargo.toml
+++ b/bin/domain/imag-contact/Cargo.toml
@@ -19,8 +19,15 @@ log = "0.3"
version = "2.0.1"
toml = "0.4"
toml-query = "^0.3.1"
+handlebars = "0.29"
+vobject = { git = 'https://github.com/matthiasbeyer/rust-vobject', branch = "next" }
+walkdir = "1"
libimagrt = { version = "0.5.0", path = "../../../lib/core/libimagrt" }
+libimagstore = { version = "0.5.0", path = "../../../lib/core/libimagstore" }
libimagerror = { version = "0.5.0", path = "../../../lib/core/libimagerror" }
libimagcontact = { version = "0.5.0", path = "../../../lib/domain/libimagcontact" }
libimagutil = { version = "0.5.0", path = "../../../lib/etc/libimagutil" }
+libimagentryref = { version = "0.5.0", path = "../../../lib/entry/libimagentryref" }
+libimaginteraction = { version = "0.5.0", path = "../../../lib/etc/libimaginteraction" }
+