summaryrefslogtreecommitdiffstats
path: root/bin/core/imag-view/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2018-04-24 15:23:32 +0200
committerMatthias Beyer <mail@beyermatthias.de>2018-04-24 18:06:45 +0200
commitc2fd3fa94efaa1879e560fa17fe01a1be78ca8c1 (patch)
treeaf6826afe06247ff4a1ac8ee77a652916c1eafd4 /bin/core/imag-view/Cargo.toml
parentd12844aff04b4b78e5aba3e79f0ba79da7326b4f (diff)
Add support for formatted markdown output
This patch also removes the (unused) "compile" subcommand and replaces it with a flag "-c" / "--compile" which prints the output in formatted to the terminal. Compiling the output from markdown to HTML and showing in the browser is not yet possible.
Diffstat (limited to 'bin/core/imag-view/Cargo.toml')
-rw-r--r--bin/core/imag-view/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/core/imag-view/Cargo.toml b/bin/core/imag-view/Cargo.toml
index 3e4c5125..ffd5706b 100644
--- a/bin/core/imag-view/Cargo.toml
+++ b/bin/core/imag-view/Cargo.toml
@@ -31,9 +31,12 @@ tempfile = "2.1"
libimagstore = { version = "0.8.0", path = "../../../lib/core/libimagstore" }
libimagrt = { version = "0.8.0", path = "../../../lib/core/libimagrt" }
libimagerror = { version = "0.8.0", path = "../../../lib/core/libimagerror" }
-libimagentryview = { version = "0.8.0", path = "../../../lib/entry/libimagentryview" }
libimagutil = { version = "0.8.0", path = "../../../lib/etc/libimagutil" }
+[dependencies.libimagentryview]
+version = "0.8.0"
+path = "../../../lib/entry/libimagentryview"
+
[dependencies.clap]
version = "^2.29"
default-features = false