summaryrefslogtreecommitdiffstats
path: root/bin/core/imag-view/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-10-08 12:55:41 +0200
committerMatthias Beyer <mail@beyermatthias.de>2017-10-08 15:08:27 +0200
commit969211174a318f65c0ad98472e852060843d6814 (patch)
treed71daa6f09656a7cc2a69682ef1e797b4405da53 /bin/core/imag-view/Cargo.toml
parentd26e8b62ac3b4ac2261c7996ed55d6f2aa5593ff (diff)
Rewrite imag-view
The imag-view command was redesigned with this change. It now looks up view-templates in the config and calls them with the "in" subcommand. This way, an entry can be viewed with editor, browser or whatever one likes. Compiling markdown is not supported yet.
Diffstat (limited to 'bin/core/imag-view/Cargo.toml')
-rw-r--r--bin/core/imag-view/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/bin/core/imag-view/Cargo.toml b/bin/core/imag-view/Cargo.toml
index 39b508b1..8bdd122c 100644
--- a/bin/core/imag-view/Cargo.toml
+++ b/bin/core/imag-view/Cargo.toml
@@ -16,7 +16,11 @@ homepage = "http://imag-pim.org"
[dependencies]
clap = ">=2.17"
log = "0.3"
+toml = "0.4"
+toml-query = "0.3"
version = "2.0.1"
+handlebars = "0.29.0"
+tempfile = "2.1"
libimagstore = { version = "0.5.0", path = "../../../lib/core/libimagstore" }
libimagrt = { version = "0.5.0", path = "../../../lib/core/libimagrt" }