summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorrabite <rabite@posteo.de>2019-07-02 00:52:49 +0200
committerrabite <rabite@posteo.de>2019-07-02 00:53:53 +0200
commitfae8706f7ab7c1141c7ae4737b12891cb23213fd (patch)
tree76893657f14094a2f4c7fa957c53b515344d5af3 /Cargo.toml
parent2c6be54944924d0da07ffc26b9d383e563b4aaa5 (diff)
got binary building to work properlyv1.3.4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 15 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ee25b80..05d3740 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@ cargo-features = ["default-run"]
[package]
name = "hunter"
-version = "1.3.0"
+version = "1.3.4"
authors = ["rabite0"]
edition = "2018"
description = "Fast, lag-free terminal file browser"
@@ -40,20 +40,29 @@ pathbuftools = "0.1"
clap = "2.33"
mime = "0.3.13"
+image = { version = "0.21.1", optional = true }
+gstreamer = { version = "0.11.2", optional = true }
+gstreamer-app = { version = "0.11.2", optional = true }
+
[build-dependencies]
termion = "1.5.1"
rustc_version = "0.2.3"
[features]
-default = ["video"]
-video = []
+default = ["img", "video"]
+video = ["gstreamer", "gstreamer-app"]
+img = ["image"]
+[[bin]]
+name = "hunter"
+path = "src/main.rs"
+[[bin]]
+name = "hunter-media"
+path = "src/hunter-media.rs"
+required-features = ["img"]
-[workspace]
-members = [".", "hunter-media"]
-default-members = [".", "hunter-media"]
[patch.crates-io]