summaryrefslogtreecommitdiffstats
path: root/hackernews_tui/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'hackernews_tui/Cargo.toml')
-rw-r--r--hackernews_tui/Cargo.toml28
1 files changed, 13 insertions, 15 deletions
diff --git a/hackernews_tui/Cargo.toml b/hackernews_tui/Cargo.toml
index 24f6495..096d9bf 100644
--- a/hackernews_tui/Cargo.toml
+++ b/hackernews_tui/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "hackernews_tui"
-version = "0.12.0"
+version = "0.13.0"
authors = ["Thang Pham <phamducthang1234@gmail.com>"]
edition = "2021"
license = "MIT"
@@ -14,9 +14,7 @@ include = ["src/**/*", "LICENSE", "../README.*", "!**/examples/**/*"]
# cursive related deps
cursive = { version = "0.20.0", default-features = false, features = ["crossterm-backend"] }
-# Pin `cursive_core` to `0.3.5` because `0.3.6` implements `ColorStyle::invert` for
-# highlighted items, which is not configurable from the `theme::Palette` struct.
-cursive_core = "=0.3.5"
+cursive_core = "0.3.7"
cursive-async-view = "0.6.0"
cursive_buffered_backend = "0.6.1"
cursive-aligned-view = "0.6.0"
@@ -27,26 +25,26 @@ markup5ever = "0.11.0"
tendril = "0.4.3"
# tracing/log related deps
-tracing = "0.1.37"
-tracing-subscriber = { version = "0.3.16", features = ["env-filter"] }
+tracing = "0.1.38"
+tracing-subscriber = { version = "0.3.17", features = ["env-filter"] }
log = "0.4.17"
# serde related deps
-serde = { version = "1.0.152", features = ["derive"] }
-serde_json = "1.0.91"
+serde = { version = "1.0.160", features = ["derive"] }
+serde_json = "1.0.96"
# others
ureq = { version = "2.6.2", features = ["json", "cookies"] }
-anyhow = "1.0.68"
-rayon = "1.6.1"
-regex = "1.7.1"
-once_cell = "1.17.0"
-toml = "0.7.0"
-clap = { version = "4.1.4", features = ["string"] }
+anyhow = "1.0.70"
+rayon = "1.7.0"
+regex = "1.8.1"
+once_cell = "1.17.1"
+toml = "0.7.3"
+clap = { version = "4.2.4", features = ["string"] }
dirs-next = "2.0.0"
url = "2.3.1"
config_parser2 = { version = "0.1.4", path = "../config_parser" }
-crossbeam-channel = "0.5.6"
+crossbeam-channel = "0.5.8"
unicode-width = "0.1.10"
comfy-table = "6.1.4"
html-escape = "0.2.13"