summaryrefslogtreecommitdiffstats
path: root/asyncgit/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'asyncgit/Cargo.toml')
-rw-r--r--asyncgit/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/asyncgit/Cargo.toml b/asyncgit/Cargo.toml
index deb9beae..40a83fff 100644
--- a/asyncgit/Cargo.toml
+++ b/asyncgit/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "asyncgit"
-version = "0.25.0"
+version = "0.26.0"
authors = ["extrawurst <mail@rusticorn.com>"]
edition = "2021"
description = "allow using git2 in a asynchronous context"
@@ -14,6 +14,7 @@ keywords = ["git"]
[dependencies]
bitflags = "2"
crossbeam-channel = "0.5"
+dirs = "5.0"
easy-cast = "0.5"
fuzzy-matcher = "0.3"
git2 = "0.18"
@@ -23,10 +24,11 @@ log = "0.4"
# git2 = { git="https://github.com/extrawurst/git2-rs.git", rev="fc13dcc", features = ["vendored-openssl"]}
# pinning to vendored openssl, using the git2 feature this gets lost with new resolver
openssl-sys = { version = '0.9', features = ["vendored"], optional = true }
-rayon = "1.8"
+rayon = "1.10"
rayon-core = "1.12"
scopetime = { path = "../scopetime", version = "0.1" }
serde = { version = "1.0", features = ["derive"] }
+ssh-key = { version = "0.6.6", features = ["crypto", "encryption"] }
thiserror = "1.0"
unicode-truncate = "0.2"
url = "2.5"