summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 10 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0df23a82..b614fa95 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "gitui"
-version = "0.25.1"
+version = "0.26.1"
authors = ["extrawurst <mail@rusticorn.com>"]
description = "blazing fast terminal-ui for git"
edition = "2021"
@@ -12,12 +12,13 @@ readme = "README.md"
license = "MIT"
categories = ["command-line-utilities"]
keywords = ["git", "gui", "cli", "terminal", "ui"]
+build = "build.rs"
[dependencies]
anyhow = "1.0"
-asyncgit = { path = "./asyncgit", version = "0.25", default-features = false }
+asyncgit = { path = "./asyncgit", version = "0.26", default-features = false }
backtrace = "0.3"
-bitflags = "2.4"
+bitflags = "2.5"
bugreport = "0.5"
bwrap = { version = "1.3", features = ["use_std"] }
bytesize = { version = "1.3", default-features = false }
@@ -55,6 +56,7 @@ syntect = { version = "5.2", default-features = false, features = [
"html",
] }
tui-textarea = "0.4.0"
+two-face = { version = "0.3.0", default-features = false }
unicode-segmentation = "1.11"
unicode-truncate = "0.2"
unicode-width = "0.1"
@@ -64,6 +66,9 @@ which = "6.0"
pretty_assertions = "1.4"
tempfile = "3"
+[build-dependencies]
+chrono = { version = "0.4", default-features = false, features = ["clock"] }
+
[badges]
maintenance = { status = "actively-developed" }
@@ -71,8 +76,8 @@ maintenance = { status = "actively-developed" }
default = ["ghemoji", "regex-fancy", "trace-libgit", "vendor-openssl"]
ghemoji = ["gh-emoji"]
# regex-* features are mutually exclusive.
-regex-fancy = ["syntect/regex-fancy"]
-regex-onig = ["syntect/regex-onig"]
+regex-fancy = ["syntect/regex-fancy", "two-face/syntect-fancy"]
+regex-onig = ["syntect/regex-onig", "two-face/syntect-onig"]
timing = ["scopetime/enabled"]
trace-libgit = ["asyncgit/trace-libgit"]
vendor-openssl = ["asyncgit/vendor-openssl"]