summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJoris Roovers <jroovers@cisco.com>2015-11-22 14:41:43 +0100
committerJoris Roovers <jroovers@cisco.com>2015-11-22 14:41:43 +0100
commite5889970784df1d6cf749a997652ccf4e97dbf33 (patch)
tree90ff2f583912f915dfded8987b8b01f166616c92 /setup.py
parent60ab3908082a2c1c06570477ce63ca8f18995387 (diff)
Doc updated prior to 0.6.0 release + Travis check for python 3.0-3.3
- Updated documentation in CHANGELOG and setup.py - Added travis checks for python 3.0-3.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 11 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 8d507e4..e5a7f36 100644
--- a/setup.py
+++ b/setup.py
@@ -10,21 +10,20 @@ del os.link
description = "Git commit message linter written in python, checks your commit messages for style."
long_description = """
-Git commit message linter written in python, checking your commit messages for style.
-
Great for use as a commit-msg git hook or as part of your gating script in a CI/CD pipeline (e.g. jenkins).
Many of the gitlint validations are based on `well-known`_ community_ `standards`_, others are based on checks that
we've found useful throughout the years. Gitlint has sane defaults, but you can also easily customize it to your
own liking.
-Details in the README_. To see what's new in the latest release, visit the CHANGELOG_.
+Demo and full documentation on `jorisroovers.github.io/gitlint`_.
+To see what's new in the latest release, visit the CHANGELOG_.
Source code on `github.com/jorisroovers/gitlint`_.
.. _well-known: http://tbaggery.com/2008/04/19/a-note-about-git-commit-messages.html
.. _community: http://addamhardy.com/blog/2013/06/05/good-commit-messages-and-enforcing-them-with-git-hooks/
.. _standards: http://chris.beams.io/posts/git-commit/
-.. _README: https://github.com/jorisroovers/gitlint/blob/master/README.md
+.. _jorisroovers.github.io/gitlint: https://jorisroovers.github.io/gitlint
.. _CHANGELOG: https://github.com/jorisroovers/gitlint/blob/master/CHANGELOG.md
.. _github.com/jorisroovers/gitlint: https://github.com/jorisroovers/gitlint
"""
@@ -43,9 +42,16 @@ setup(
description=description,
long_description=long_description,
classifiers=[
- "Development Status :: 4 - Beta",
+ "Development Status :: 5 - Production/Stable",
"Operating System :: OS Independent",
"Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3.0",
+ "Programming Language :: Python :: 3.1",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
"Environment :: Console",
"Intended Audience :: Developers",
"Topic :: Software Development :: Quality Assurance",