summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorariasuni <perso@hack-libre.org>2021-05-06 02:21:06 +0200
committerMélanie Chauvel <perso@hack-libre.org>2021-09-17 20:58:49 +0200
commit75f14d23a3be0951bc409a244e57c1c4d6501e10 (patch)
tree97cc34a56d428ef3598970d93b91d2961bcc88b7 /Cargo.toml
parent11793973fe0851dfe075a15d877116485abc4e50 (diff)
Update Cargo.toml to make cargo-deb work again
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 7 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index abb484d..d2923f5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,11 +1,11 @@
[package]
name = "exa"
description = "A modern replacement for ls"
-
authors = ["Benjamin Sago <ogham@bsago.me>"]
categories = ["command-line-utilities"]
edition = "2018"
exclude = ["/devtools/*", "/Justfile", "/Vagrantfile", "/screenshots.png"]
+readme = "README.md"
homepage = "https://the.exa.website/"
license = "MIT"
repository = "https://github.com/ogham/exa"
@@ -63,7 +63,7 @@ lto = true
[package.metadata.deb]
-license-file = [ "LICENCE" ]
+license-file = [ "LICENCE", "4" ]
depends = "$auto"
extended-description = """
exa is a replacement for ls written in Rust.
@@ -72,6 +72,9 @@ section = "utils"
priority = "optional"
assets = [
[ "target/release/exa", "/usr/bin/exa", "0755" ],
- [ "contrib/man/exa.1", "/usr/share/man/man1/exa.1", "0644" ],
- [ "contrib/completions.bash", "/etc/bash_completion.d/exa", "0644" ],
+ [ "target/release/../man/exa.1", "/usr/share/man/man1/exa.1", "0644" ],
+ [ "target/release/../man/exa_colors.5", "/usr/share/man/man5/exa_colors.5", "0644" ],
+ [ "completions/bash/exa", "/usr/share/bash-completion/completions/exa", "0644" ],
+ [ "completions/zsh/_exa", "/usr/share/zsh/site-functions/_exa", "0644" ],
+ [ "completions/fish/exa.fish", "/usr/share/fish/vendor_completions.d/exa.fish", "0644" ],
]