summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBenjamin Sago <ogham@bsago.me>2020-10-10 02:01:12 +0100
committerBenjamin Sago <ogham@bsago.me>2020-10-10 02:01:12 +0100
commit04e2d4c69295f6990023955d0e930e702e691553 (patch)
tree94b10825de510a233c4ff20631e9724e0ab862c3 /Cargo.toml
parent3b209d1127d7478c7e2f499cadf3ef5bca8b4195 (diff)
Just straight-up roll our own logger
This commit removes the env_logger dependency, replacing it with a simple implementation. Doing so removes like ten other transitive dependencies that no longer need to be included in the build. It also gains the ability to enable trace-level logging. The users crate, which contains such logging statements as of the version I published a few days ago, has been upgraded to celebrate. Also, change the log imports to globs. I'm only interested that a file doing logging, not what level it's logging at.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d3862c3..fcb94d5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,7 +24,6 @@ name = "exa"
[dependencies]
ansi_term = "0.12.0"
datetime = "0.5"
-env_logger = "0.6.1"
glob = "0.3.0"
lazy_static = "1.3.0"
libc = "0.2.51"
@@ -37,7 +36,7 @@ scoped_threadpool = "0.1.9"
term_grid = "0.1.7"
term_size = "0.3.1"
unicode-width = "0.1.5"
-users = "0.10"
+users = "0.11"
zoneinfo_compiled = "0.5"
[dependencies.git2]