summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPaul Woolcock <paul@woolcock.us>2020-10-07 05:47:39 -0400
committerPaul Woolcock <paul@woolcock.us>2020-10-07 09:06:13 -0400
commit02ca0a89515413ac9fb3b655de2f21f6a711e0f2 (patch)
tree004bcd9f88eca168e10e1ac85c5987fdd6769fcf /Cargo.toml
parent04b5b54212629f058bdab1ba55c89a3d417e0454 (diff)
Add basic async client
This adds a module, accessible by compiling with `--features async`, that provides an `elefren::async::Client`. The client is runtime-agnostic, and currently only provides unauthenticated access, see the docs for the full list of methods that can be performed* with this client. * note that some API calls are publicly available by default, but can be changed via instance settings to not be publicly accessible
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ad8b9c1..3736ba9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,6 +27,11 @@ toml = { version = "0.5.0", optional = true }
tungstenite = "0.11.0"
async-trait = "0.1.40"
tokio = "0.2.22"
+async-h1 = { version = "2.1.2", optional = true }
+async-native-tls = { version = "0.3.3", optional = true }
+smol = { version = "1.2.2", optional = true }
+http-types = { version = "2.5.0", optional = true }
+async-mutex = { version = "1.4.0", optional = true }
[dependencies.chrono]
version = "0.4"
@@ -36,9 +41,10 @@ features = ["serde"]
default = ["reqwest/default-tls"]
json = []
env = ["envy"]
-all = ["toml", "json", "env"]
+all = ["toml", "json", "env", "async"]
rustls-tls = ["reqwest/rustls-tls"]
nightly = []
+async = ["async-h1", "async-native-tls", "smol", "http-types", "async-mutex"]
[dev-dependencies]
tempfile = "3.0.3"