summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2021-07-14 08:35:06 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2021-07-14 08:35:06 +0800
commitb12b98a07935c839a11af08cfa9dc872b5a127e8 (patch)
tree898b0962b75eb87af194c288e24de20df2ea0c70 /Cargo.toml
parent64175e028965958d0c22f8ffe55cab2fc01f9fc8 (diff)
parent6894dd8db51cd6fe8a70ad0c906ef351dc0a720c (diff)
Merge branch 'optional-trash'
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 026f130..a93721f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,11 +10,12 @@ license = "MIT"
include = ["src/**/*", "Cargo.*", "LICENSE", "README.md", "CHANGELOG.md", "!**/tests/*"]
[features]
-default = ["tui-crossplatform"]
+default = ["tui-crossplatform", "trash-move"]
tui-unix = ["crosstermion/tui-react-termion", "tui-shared"]
tui-crossplatform = ["crosstermion/tui-react-crossterm", "tui-shared"]
tui-shared = ["tui", "tui-react", "open", "unicode-segmentation"]
+trash-move = ["trash"]
[dependencies]
clap = "3.0.0-beta.2"
@@ -27,7 +28,7 @@ num_cpus = "1.10.0"
filesize = "0.2.0"
anyhow = "1.0.31"
colored = "2.0.0"
-trash = "2.0.1"
+trash = { version = "2.0.1", optional = true }
# 'tui' related
unicode-segmentation = { version = "1.3.0", optional = true }