summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2023-12-09 19:14:11 +0100
committerSebastian Thiel <sebastian.thiel@icloud.com>2023-12-09 19:14:11 +0100
commitaf2aa61813578ecc9f6ccaba5e94049fc6ddf727 (patch)
tree018265e505f59cbb001520dcbb709e4c172ded39 /Cargo.toml
parent852ee281ca89cb58cf404e8179d4e590f6da87b7 (diff)
upgrade to latest crossterm; switch to `ratatui` from `tui`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 817b94c..8538485 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,9 +32,9 @@ chrono = { version = "0.4.31", default-features = false, features = ["std"] }
# 'tui' related
unicode-segmentation = { version = "1.3.0", optional = true }
-crosstermion = { version = "0.10.1", default-features = false, optional = true }
-tui = { version = "0.19.0", optional = true, default-features = false }
-tui-react = { version = "0.19.0", optional = true }
+crosstermion = { version = "0.12.0", default-features = false, optional = true }
+tui = { package = "ratatui", version = "0.24.0", optional = true, default-features = false }
+tui-react = { version = "0.21.0", optional = true }
open = { version = "5.0", optional = true }
wild = "2.0.4"
owo-colors = "3.5.0"