summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCyandev <unixzii@gmail.com>2024-01-05 19:43:35 +0800
committerCyandev <unixzii@gmail.com>2024-01-05 19:43:35 +0800
commit983ba6172604b83c2e4efad0f03273206a43c5db (patch)
tree3765bce77937e991398e40c9f96e0077e1ba0405 /Cargo.toml
parentad7c77ac8db663e7a870dd73e45159462c1cbe60 (diff)
Optimize UI responsiveness during scanning state
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 89cfe39..e2856c0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,7 +11,7 @@ include = ["src/**/*", "Cargo.*", "LICENSE", "README.md", "CHANGELOG.md", "!**/t
[features]
default = ["tui-crossplatform", "trash-move"]
-tui-crossplatform = ["crosstermion/tui-react-crossterm", "tui", "tui-react", "open", "unicode-segmentation", "unicode-width"]
+tui-crossplatform = ["crosstermion/tui-react-crossterm", "crossterm", "tui", "tui-react", "open", "unicode-segmentation", "unicode-width"]
trash-move = ["trash"]
@@ -32,6 +32,7 @@ chrono = { version = "0.4.31", default-features = false, features = ["std"] }
unicode-segmentation = { version = "1.3.0", optional = true }
unicode-width = { version = "0.1.5", optional = true }
crosstermion = { version = "0.13.0", default-features = false, optional = true }
+crossterm = { version = "0.27", optional = true }
tui = { package = "ratatui", version = "0.25.0", optional = true, default-features = false }
tui-react = { version = "0.22.0", optional = true }
open = { version = "5.0", optional = true }
@@ -45,6 +46,7 @@ bstr = "1.8.0"
simplelog = "0.12.1"
log = "0.4.20"
log-panics = { version = "2", features = ["with-backtrace"]}
+crossbeam = "0.8"
[[bin]]
name="dua"