summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2023-12-26 20:31:43 +0100
committerSebastian Thiel <sebastian.thiel@icloud.com>2023-12-26 20:49:56 +0100
commit90b65d59f5dde888f81c42e3c812670929b1740a (patch)
tree0cabc5213fe69eaab1b5bf72aa989ff34648486e /Cargo.toml
parent46fece5f295a8fb6f90ff969741f79d7c736c140 (diff)
upgrade to latest verison of tui-crates and native crossterm events. (#203)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a15e1c7..0c8e35a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,7 +11,6 @@ include = ["src/**/*", "Cargo.*", "LICENSE", "README.md", "CHANGELOG.md", "!**/t
[features]
default = ["tui-crossplatform", "trash-move"]
-tui-unix = ["crosstermion/tui-react-termion", "tui-shared"]
tui-crossplatform = ["crosstermion/tui-react-crossterm", "tui-shared"]
tui-shared = ["tui", "tui-react", "open", "unicode-segmentation", "unicode-width"]
@@ -33,9 +32,9 @@ chrono = { version = "0.4.31", default-features = false, features = ["std"] }
# 'tui' related
unicode-segmentation = { version = "1.3.0", optional = true }
unicode-width = { version = "0.1.5", optional = true }
-crosstermion = { version = "0.12.0", default-features = false, optional = true }
-tui = { package = "ratatui", version = "0.24.0", optional = true, default-features = false }
-tui-react = { version = "0.21.0", optional = true }
+crosstermion = { version = "0.13.0", default-features = false, optional = true }
+tui = { package = "ratatui", version = "0.25.0", optional = true, default-features = false }
+tui-react = { version = "0.22.0", optional = true }
open = { version = "5.0", optional = true }
wild = "2.0.4"
owo-colors = "4.0.0"