summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2023-12-27 10:20:01 +0100
committerSebastian Thiel <sebastian.thiel@icloud.com>2023-12-27 10:23:35 +0100
commit6fbe17ff51360d62086aa265a0baa9288175cb84 (patch)
tree2f21bab362c07efb96a206116a4bfb7bec6d740c /Cargo.toml
parent45d886a6b2c194a5a68961b428f8db2c8daf06a8 (diff)
feat: add `--log-file` flag to keep track of some debug info, which includes panics.
Previously, when `dua i` was used, panics would be hard to observe, if at all, as they would print to the alternate screen. Now, when the `--log-file dua.log` is specified, the panic will be emitted into the log file instead and thus won't be lost anymore. This may help with debugging in future.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5a1a000..54ef47e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,6 +45,7 @@ gix-path = "0.10.1"
bstr = "1.8.0"
simplelog = "0.12.1"
log = "0.4.20"
+log-panics = { version = "2", features = ["with-backtrace"]}
[[bin]]
name="dua"