summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2a40fb4..0e6a3d0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -69,7 +69,12 @@ datetime = { version = "0.5.1", default_features = false }
pretty_assertions = "0.7"
[features]
-default = ["with_idna", "with_tls", "with_https"]
+default = ["with_idna", "with_tls", "with_https", "with_nativetls"]
with_idna = ["dns/with_idna"]
+
with_tls = ["dns-transport/with_tls"]
with_https = ["dns-transport/with_https"]
+
+with_nativetls = ["dns-transport/with_nativetls"]
+with_nativetls_vendored = ["with_nativetls", "dns-transport/with_nativetls", "dns-transport/with_nativetls_vendored"]
+with_rustls = ["dns-transport/with_rustls"]