summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 01160ab..d6324a8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -18,10 +18,21 @@ let
dbus
libtool
];
+
+ gtk = with pkgs; [
+ glib
+ pango
+ gdk-pixbuf
+ atk
+ gtk3
+
+ libsoup
+ webkitgtk
+ ];
in
pkgs.mkShell rec {
- buildInputs = env ++ dependencies;
+ buildInputs = env ++ dependencies ++ gtk;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
}