summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-05-03 23:39:26 +0200
committerMatthias Beyer <mail@beyermatthias.de>2020-05-12 18:01:02 +0200
commitf475a18746c337440d59592af484e857237f9064 (patch)
tree2726a8bad28eeab59915b7515aa6f4a3fce4eba3 /shell.nix
parent339db755fed1720c53a57f29961eb55bd592cf37 (diff)
Add dependencies for development with gtk
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 01160ab..d6324a8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -18,10 +18,21 @@ let
dbus
libtool
];
+
+ gtk = with pkgs; [
+ glib
+ pango
+ gdk-pixbuf
+ atk
+ gtk3
+
+ libsoup
+ webkitgtk
+ ];
in
pkgs.mkShell rec {
- buildInputs = env ++ dependencies;
+ buildInputs = env ++ dependencies ++ gtk;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
}