summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix28
1 files changed, 27 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index e659c40..32a0774 100644
--- a/shell.nix
+++ b/shell.nix
@@ -22,11 +22,37 @@ let
pkgconfig
which
zlib
+
+ freetype
+ expat
+ ];
+ xorgPackages = with pkgs.xorg; [
+ libXcursor
+ libXfont2
+ # libXpm
+ # libXtst
+ # libxshmfence
+ # libXft
+ libXrandr
+ libXext
+ # libXinerama
+ # libXrender
+ # libXxf86misc
+ # libxcb
+ libX11
+ # libXcomposite
+ libXfont
+ libXi
+ # libXt
+ # libxkbfile
+
+ pkgs.libGL
];
in
pkgs.mkShell rec {
- buildInputs = env ++ dependencies;
+ buildInputs = env ++ dependencies ++ xorgPackages;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
PROTOC = "${pkgs.protobuf}/bin/protoc";
+ LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath xorgPackages;
}