summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix56
1 files changed, 38 insertions, 18 deletions
diff --git a/shell.nix b/shell.nix
index d6324a8..32a0774 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,38 +1,58 @@
-{ pkgs ? (import <nixpkgs> {}) }:
+{ ... }:
let
- env = with pkgs.rustChannels.stable; [
- rust
- cargo
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+
+ env = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
];
dependencies = with pkgs; [
cmake
curl
gcc
- libpsl
openssl
pkgconfig
which
zlib
- dbus
- libtool
- ];
- gtk = with pkgs; [
- glib
- pango
- gdk-pixbuf
- atk
- gtk3
+ freetype
+ expat
+ ];
+ xorgPackages = with pkgs.xorg; [
+ libXcursor
+ libXfont2
+ # libXpm
+ # libXtst
+ # libxshmfence
+ # libXft
+ libXrandr
+ libXext
+ # libXinerama
+ # libXrender
+ # libXxf86misc
+ # libxcb
+ libX11
+ # libXcomposite
+ libXfont
+ libXi
+ # libXt
+ # libxkbfile
- libsoup
- webkitgtk
+ pkgs.libGL
];
in
pkgs.mkShell rec {
- buildInputs = env ++ dependencies ++ gtk;
+ buildInputs = env ++ dependencies ++ xorgPackages;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+ PROTOC = "${pkgs.protobuf}/bin/protoc";
+ LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath xorgPackages;
}
-