summaryrefslogtreecommitdiffstats
path: root/cli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'cli/Cargo.toml')
-rw-r--r--cli/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/cli/Cargo.toml b/cli/Cargo.toml
new file mode 100644
index 0000000..e558c19
--- /dev/null
+++ b/cli/Cargo.toml
@@ -0,0 +1,49 @@
+[package]
+name = "distrox-cli"
+version = "0.1.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+
+description = "Distributed network build on IPFS, CLI frontend"
+
+keywords = ["social", "network", "ipfs", "distributed"]
+readme = "README.md"
+license = "GPL-2.0"
+
+documentation = "https://docs.rs/distrox"
+repository = "https://github.com/matthiasbeyer/distrox"
+homepage = "http://github.com/matthiasbeyer/distrox"
+
+edition = "2018"
+
+[dependencies]
+anyhow = "1"
+async-trait = "0.1"
+chrono = { version = "0.4", features = ["serde"] }
+cid = "0.5"
+clap = "3.0.0-beta.5"
+daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
+env_logger = "0.8"
+futures = "0.3"
+log = "0.4"
+tokio = { version = "1", features = ["full", "rt", "macros"] }
+mime = "0.3"
+rand_core = { version = "0.6", features = ["getrandom"] }
+rand_os = "0.2"
+ed25519-dalek = "*"
+http = "0.2"
+serde = "1"
+serde_json = "1"
+getset = "0.1"
+xdg = "2.4"
+tracing = "0.1"
+ctrlc = "3.2"
+
+[dependencies.ipfs]
+git = "https://github.com/rs-ipfs/rust-ipfs/"
+rev = "ad3ab49b4d9236363969b0f74f14aabc7c906b3b"
+
+[dependencies.distrox-lib]
+path = "../lib"
+
+[dev-dependencies]
+multibase = "0.8"