summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml54
1 files changed, 6 insertions, 48 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6766fe6..f0e2060 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,48 +1,6 @@
-[package]
-name = "distrox"
-version = "0.1.0"
-authors = ["Matthias Beyer <mail@beyermatthias.de>"]
-
-description = "Distributed network build on IPFS"
-
-keywords = ["social", "network", "ipfs", "distributed"]
-readme = "README.md"
-license = "GPL-2.0"
-
-documentation = "https://docs.rs/distrox"
-repository = "https://github.com/matthiasbeyer/distrox"
-homepage = "http://github.com/matthiasbeyer/distrox"
-
-edition = "2018"
-
-[dependencies]
-anyhow = "1"
-async-trait = "0.1"
-chrono = { version = "0.4", features = ["serde"] }
-cid = "0.5"
-clap = "3.0.0-beta.5"
-daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
-env_logger = "0.8"
-futures = "0.3"
-log = "0.4"
-tokio = { version = "1", features = ["full", "rt", "macros"] }
-mime = "0.3"
-rand_core = { version = "0.6", features = ["getrandom"] }
-rand_os = "0.2"
-ed25519-dalek = "*"
-http = "0.2"
-serde = "1"
-serde_json = "1"
-getset = "0.1"
-xdg = "2.4"
-libp2p = "0.39.1"
-tracing = "0.1"
-ctrlc = "3.2"
-
-[dependencies.ipfs]
-git = "https://github.com/rs-ipfs/rust-ipfs/"
-rev = "ad3ab49b4d9236363969b0f74f14aabc7c906b3b"
-
-
-[dev-dependencies]
-multibase = "0.8"
+[workspace]
+members = [
+ "cli",
+ "gui",
+ "lib",
+]