summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml51
1 files changed, 6 insertions, 45 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a53ead9..f0e2060 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,45 +1,6 @@
-[package]
-name = "distrox"
-version = "0.1.0"
-authors = ["Matthias Beyer <mail@beyermatthias.de>"]
-
-description = "Distributed network build on IPFS"
-
-keywords = ["social", "network", "ipfs", "distributed"]
-readme = "README.md"
-license = "GPL-2.0"
-
-documentation = "https://docs.rs/distrox"
-repository = "https://github.com/matthiasbeyer/distrox"
-homepage = "http://github.com/matthiasbeyer/distrox"
-
-edition = "2018"
-
-[dependencies]
-is-match = "0.1"
-anyhow = "1"
-futures = "0.3"
-ipfs-api = { version = "0.7", features = ["actix"], default-features = false }
-serde = "1"
-serde_derive = "1"
-serde_json = "1"
-mime = "0.3"
-chrono = { version = "0.4", features = ["serde"] }
-uuid = { version = "0.7", features = ["serde", "v4"] }
-clap = "2"
-log = "0.4"
-env_logger = "0.7"
-config = "0.9"
-toml = "0.4"
-hyper = "0.12"
-itertools = "0.7"
-tokio = { version = "0.2", features = ["full"] }
-add_getters_setters = "1.1"
-xdg = "2"
-structopt = "0.3"
-web-view = "0.6"
-handlebars = "3"
-actix-rt = "1"
-actix-web = "2"
-failure = "0.1"
-pidlock = { git = "https://github.com/matthiasbeyer/pidlock", branch = "my-master" }
+[workspace]
+members = [
+ "cli",
+ "gui",
+ "lib",
+]