summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-12-02 20:32:43 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-12-08 18:43:34 +0100
commit969de98ddad7311fbcd74f93910444af8fdb7882 (patch)
treee48aa0a2da01ad9c6620ee943e8e78e9e19f0db6 /shell.nix
parent7f253887d9d594fc7c2afdc001395c7848d49a16 (diff)
Add xorg dependencies in dev shell
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 24 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 8abcf47..32a0774 100644
--- a/shell.nix
+++ b/shell.nix
@@ -26,10 +26,33 @@ let
freetype
expat
];
+ xorgPackages = with pkgs.xorg; [
+ libXcursor
+ libXfont2
+ # libXpm
+ # libXtst
+ # libxshmfence
+ # libXft
+ libXrandr
+ libXext
+ # libXinerama
+ # libXrender
+ # libXxf86misc
+ # libxcb
+ libX11
+ # libXcomposite
+ libXfont
+ libXi
+ # libXt
+ # libxkbfile
+
+ pkgs.libGL
+ ];
in
pkgs.mkShell rec {
- buildInputs = env ++ dependencies;
+ buildInputs = env ++ dependencies ++ xorgPackages;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
PROTOC = "${pkgs.protobuf}/bin/protoc";
+ LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath xorgPackages;
}