summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-12-04 17:03:09 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-12-04 21:16:37 +0100
commite5d610270bed47a91ecca8d51adc705bed58cda7 (patch)
tree52a5d63edbbf5f8bbf154757969877bce17c3725 /Cargo.toml
parent3a3b342a4ae5a90003b6ef9faa65ca7f0a025962 (diff)
Rewrite using "ipfs" crate
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 11 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1d2638d..553f189 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,17 +19,14 @@ edition = "2018"
anyhow = "1"
async-trait = "0.1"
chrono = { version = "0.4", features = ["serde"] }
-cid = "0.7"
+cid = "0.5"
clap = "3.0.0-beta.5"
daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
env_logger = "0.8"
futures = "0.3"
-ipfs-api-backend-hyper = { version = "0.2", features = [ "with-hyper-tls" ] }
log = "0.4"
tokio = { version = "1", features = ["full", "rt", "macros"] }
mime = "0.3"
-libipld-cbor = "0.12"
-libipld = "0.12"
rand_core = { version = "0.6", features = ["getrandom"] }
rand_os = "0.2"
ed25519-dalek = "*"
@@ -38,3 +35,13 @@ serde = "1"
serde_json = "1"
getset = "0.1"
xdg = "2.4"
+libp2p = "0.41"
+tracing = "0.1"
+
+[dependencies.ipfs]
+git = "https://github.com/rs-ipfs/rust-ipfs/"
+rev = "ad3ab49b4d9236363969b0f74f14aabc7c906b3b"
+
+
+[dev-dependencies]
+multibase = "0.8"